- Sep 2021
Good move. Rather than having 2 different methods, and requiring people to "go out of their way" to "opt in" to using chunks by using the longer-named
Now they don't need 2 similar but separate methods that do nearly the same, which makes things simpler and easier to understand (no longer have to stop and ask oneself, which one should I use? what's the difference?).
You can't get it "wrong" now because there's only one option.
And by switching that method to use the shorter name, it makes it clearer that that is the usual/common/recommended way to go.
- make it hard to get wrong/incorrect
- constant evolution/improvement of software/practices/solutions
- removing features to simplify implementation
- newer/better ways of doing things
- fewer options: pros: don't have ask which one should I use? what's the difference?