- Oct 2024
-
answers.microsoft.com answers.microsoft.com
-
I am just surprised that there is no clear official name for such a popular and well known convention. Internet searching seems to indicate that the common term used is "Red Squiggly Line", but it seems like a term quickly made-up just to describe something for which we know no name. There's a technical name for the dot on an "i" for goodness sake (tittle).
-
- Mar 2024
-
stackoverflow.com stackoverflow.com
-
Please use $needle in a $haystack idiom in your example. It's much easier to read and understand.
-
- Feb 2024
-
unix.stackexchange.com unix.stackexchange.com
-
This follows on a fairly widespread practice in various programming languages to use a leading underscore to indicate that a function or variable is in some way internal to a library and not intended for the end-user (or end-programmer).
-
- Aug 2022
-
stackoverflow.com stackoverflow.com
-
The vendor prefix (vnd.) indicates that it is custom for this vendor.
-
The +json indicates that it can be parsed as JSON, but the media type should define further semantics on top of JSON.
-
- Aug 2021
-
medium.com medium.com
-
arguments = method_proc.parameters.map(&:last)
Gets names of parameters, like
[:arg_a, :b]
Should be called
parameter_names
(the key word being names). "arguments
" implies that it is the actual values that were passed in — not the name of the variables to which they will be assigned.
-
- Jun 2021
-
evilmartians.com evilmartians.com
-
“System tests” is a common naming for automated end-to-end tests in the Rails world. Before Rails adopted this name, we used such variations as feature tests, browser tests
-
- May 2021
-
stefaniefluin.medium.com stefaniefluin.medium.com
-
1. The main folder names have numbers in front of them, such as 0-base to ensure that the folders stay in that particular order. You can certainly omit this or choose different folder names.
-
- Feb 2021
-
github.com github.com
-
value returned from #execute
Why not follow Ruby Proc convention of calling it
call
?execute seems like a synonym for call, so given these 2 equivalent options, it seems better to prefer the one more idiomatic in Ruby.
-
By convention, we call this an outcome
-
Call .run on your interaction to execute it.
Why not follow Ruby Proc convention of calling it
call
?run seems like a synonym for call, so given these 2 equivalent options, it seems better to prefer the one more idiomatic in Ruby.
-
-
-
if you name you instance variable form, then you can always just pass in params[:form]
-
- Dec 2020
-
blog.kotlin-academy.com blog.kotlin-academy.com
-
Handlers are normally not suffixed, but instead, they most often have on as the prefix (onClick, onSwipe etc.).
-
Listeners are often objects, so they are commonly suffixed with Listener.
-
- Nov 2020
-
developer.mozilla.org developer.mozilla.org
-
The Object.getPrototypeOf() method returns the prototype (i.e. the value of the internal [[Prototype]] property) of the specified object.
internal: [[Prototype]]
Other times we see something used to indicate it is internal. In fact, this even supersedes proto__. So why did they use a different naming convention? Did they decide [[ ]] is a better naming convention?
-
- Oct 2020
-
github.com github.com
-
For event listeners we support the standard jsx naming convention onEventname (this is converted to on:eventname in svelte) as well.
-
- Sep 2020
-
www.javascriptjanuary.com www.javascriptjanuary.com
-
The problem I have with this approach to state and prop variables is that the difference between them is very blurry. In React you can clearly see that a prop is an input to component (because of clear function notation), and that state is something internal. In Svelte they are both just variables, with the exception that props use export keyword.
This is something I've seen before: people noticing that Svelte is missing some kind of naming convention.
React has use___ convention, for example. Without that, it makes it hard to see the difference between and know just from the name that a function is an (mentioned in the other article I read) action and not a event handler or even component, for example.
-
-
github.com github.com
-
I like use. But we would still need a noun to reference them by in the docs or libraries.
-
one problem with 'behavior' is that's the terminology we use to describe all of a component's encapsulated logic — methods, transitions, etc.
-
-
github.com github.com
-
The above doesn't work for another unfortunate reason, it's not possible to write export let class = ''; instead CustomComponent because class is a reserved keyword and isn't allowed to be used as a variable name. The workaround would have to be to use some other prop name like maybe cssClass but then there's no "standard" by which all Svelte components can follow and every library will choose a different name which is cumbersome for users, because it creates scenarios like:
-
- Jun 2020
-
docs.syncthing.net docs.syncthing.net
-
Is it “syncthing”, “Syncthing” or “SyncThing”?¶ It’s Syncthing, although the command and source repository is spelled syncthing so it may be referred to in that way as well. It’s definitely not SyncThing, even though the abbreviation st is used in some circumstances and file names.
-
- May 2020
-
docs.gitlab.com docs.gitlab.com
-
To follow conventions of naming across GitLab, and to further move away from the build term and toward job, some CI/CD environment variables were renamed for GitLab 9.0 release.
-
- Apr 2020
-
en.wikipedia.org en.wikipedia.org
-
Some conventions reverse the order of priorities, considering lower values to be higher priority
-
-
github.com github.com
-
Then I modeled the the contributing.md and development.md after bundler's files and they use uppercase for those and so I did.
-
- Mar 2020
-
github.com github.com
-
On rare occasion two or more methods can be very tightly related. In these cases the methods can all go in a single file under the name of the method considered most significant. Usually files for the other methods should still be created that simply require the main file.
-
- Jan 2020
-
allnurses.com allnurses.com
-
chart the index finger as the 2nd finger, middle finger as the 3rd, ring finger as the 4th, and pinky as the 5th finger
-
- Dec 2019
-
github.com github.com
-
return <Lower
Interesting naming convention: Higher and Lower components.
-
- Nov 2019
-
gist.github.com gist.github.com
-
gist.github.com gist.github.com
-
Not yet sure when I would need immutable components...
-
-
gist.github.com gist.github.com
-
The idea is that the additional prefix _ of a Null Component symbolizes that it adds even less to the DOM than an Injector. I picture the name falling through to become just the _, like the unused argument convention in javascript functions: const handleEvent = (_, id) => { console.log(id) } .
-
- Sep 2019
-
suitcss.github.io suitcss.github.io